2024-06-18

Proxmox VE更新出了问题

在公司用Proxmox VE搭了一个「超融合」环境,开了一些VPS给同事用。因为没打算花钱,所以一直用的未订阅方式进行更新。

今天跑apt dist-upgrade的时候,遇到一大串内容:

root@pve:~# apt dist-upgrade
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Calculating upgrade... Done
The following package was automatically installed and is no longer required:
  proxmox-kernel-6.8.4-3-pve-signed
Use 'apt autoremove' to remove it.
The following packages will be REMOVED:
  proxmox-ve pve-manager
The following packages have been kept back:
  pve-container
The following packages will be upgraded:
  libpve-cluster-api-perl libpve-cluster-perl libpve-notify-perl libpve-rs-perl
4 upgraded, 0 newly installed, 2 to remove and 1 not upgraded.

我也没有细看,一个回车按下去,报了一些错:

Do you want to continue? [Y/n] y
W: (pve-apt-hook) !! WARNING !!
W: (pve-apt-hook) You are attempting to remove the meta-package 'proxmox-ve'!
W: (pve-apt-hook)
W: (pve-apt-hook) If you really want to permanently remove 'proxmox-ve' from your system, run the following command
W: (pve-apt-hook)       touch '/please-remove-proxmox-ve'
W: (pve-apt-hook) run apt purge proxmox-ve to remove the meta-package
W: (pve-apt-hook) and repeat your apt invocation.
W: (pve-apt-hook)
W: (pve-apt-hook) If you are unsure why 'proxmox-ve' would be removed, please verify
W: (pve-apt-hook)       - your APT repository settings
W: (pve-apt-hook)       - that you are using 'apt full-upgrade' to upgrade your system
E: Sub-process /usr/share/proxmox-ve/pve-apt-hook returned an error code (1)
E: Failure running script /usr/share/proxmox-ve/pve-apt-hook

我这个笨蛋还是没有细想,按照提示操作了,随后重启了这台宿主机。
然后上面的VPS就启动不起来了。既没有自动启动,也无法打开Web控制台进行操作。netstat一看,HTTP端口监听没有了。

心里慌了,连忙上网搜,才发现好多人都在叫唤。只不过我是其中心比较大,真的操作了的那个白痴。更多人是在报错那步停下来了。

这下怎么办呢?翻了下日志,看到proxmox-ve和pve-manager被remove了。我想把proxmox-ve给装回来,又有报错,看来不行:

root@pve:~# apt install proxmox-ve
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 pve-container : Depends: proxmox-backup-client (>= 3.2.5-1) but 3.2.3-1 is to be installed
E: Unable to correct problems, you have held broken packages.

还好,讨论帖里面有人给出了抢救措施:

apt install pve-manager=8.2.3

操作以后,Web控制台出现了。我进去启动了VPS,用起来没有什么问题。
先这样吧,接下来就是等官方消息了。
我们应该都是没花钱的用户,也许官方不一定会有修正?

-- 更新于2024.06.19:

官方已经为未订阅apt源修正了这个问题

没有评论:

发表评论